Page MenuHomePhabricator

Bump cmake version 3.5 -> 3.10 to match lowest supported version for CMP0071
Needs RevisionPublic

Authored by jasonbcox on Sat, Jan 5, 23:24.

Details

Reviewers
deadalnix
Fabien
Group Reviewers
Restricted Project
Summary

Discovered using cmake 3.5, a clean configuration step would result in
and error that CMP0071 is not supported. CMP0071 was introduced in 3.10.

Co-authored-by: Fabien <fabcien@gmail.com>

Test Plan

Uninstall cmake (if applicable) and then install cmake 3.10+ (I installed 3.13.2 latest)

# Entirely clean build directory
rm build
mkdir build
cd build
cmake -GNinja ..

Verify the CMP0071 error no longer appears.

ninja

Verify builds as expected.

Diff Detail

Repository
rABC Bitcoin ABC
Branch
master
Lint
Lint OK
Unit
No Unit Test Coverage
Build Status
Buildable 4422
Build 6909: Bitcoin ABC Teamcity Staging
Build 6908: arc lint + arc unit

Event Timeline

jasonbcox created this revision.Sat, Jan 5, 23:24
Herald added a reviewer: Restricted Project. · View Herald TranscriptSat, Jan 5, 23:25
Herald added a subscriber: schancel. · View Herald Transcript
deadalnix requested changes to this revision.Sat, Jan 5, 23:49

Considering CMP0071 is set to old, this seems dubious that it is actually the problem you are encountering. I would like to know what the problem is specifically in order to be able to judge the solution.

This revision now requires changes to proceed.Sat, Jan 5, 23:49

Memory is getting fuzzy since this was a week or so ago... but Fabien and I were investigating bitcoin-qt not building with cmake 3.5. We found that an error was appearing that CMP0071 wasn't supported, so we tried various methods of disabling CMP0071 if the policy was not found. This resulting in a protobuf compilation failure that I'm not very familiar with. Instead of futzing with the protobuf dependency, we opted to bump the cmake version. This works with no other changes.

@Fabien do you remember any more details?