Page MenuHomePhabricator

Rename ui_interface.* to uiinterface.*
AbandonedPublic

Authored by Fabien on Mar 27 2019, 12:53.

Details

Reviewers
deadalnix
Group Reviewers
Restricted Project
Summary

The file name ui_interface.h uses the same naming pattern as the
auto-generated headers from the *.ui files, i.e. ui_*.h.
This makes it impossible to use the CMake AUTOUIC feature, leading to
the maintenance of an exhaustive list of all the *.ui files to
convert.

This renaming will allow to enable the CMake AUTOUIC feature.

Test Plan
make check
ninja check

Diff Detail

Repository
rABC Bitcoin ABC
Branch
rename_ui_interface
Lint
Lint OK
Unit
No Unit Test Coverage
Build Status
Buildable 5314
Build 8690: Bitcoin ABC Teamcity Staging
Build 8689: arc lint + arc unit

Event Timeline

Fabien created this revision.Mar 27 2019, 12:53
Herald added a reviewer: Restricted Project. · View Herald TranscriptMar 27 2019, 12:53
Herald added a subscriber: schancel. · View Herald Transcript
deadalnix requested changes to this revision.Mar 27 2019, 14:39

Having the list is not a problem. Without the list there are no way for cmake to track dependencies properly, so it must either assume the worse or miss some.

This revision now requires changes to proceed.Mar 27 2019, 14:39
Fabien abandoned this revision.Mar 28 2019, 08:28

Talked offline, will try another approach