190bf62be1214b072513c7fd7e01cc191723967c scripted-diff: Small locking rename (Russell Yanofsky)
Pull request description:
Call sync.h primitives "locks" and "mutexes" instead of "blocks" and "waitable critical sections" to match current coding conventions and c++11 standard names.
This PR does not rename the "CCriticalSection" class (though this could be done as a followup) because it's used everywhere and would swamp the other changes in this PR. Plain mutexes should mostly be preferred instead of recursive mutexes in new code anyway.
Backport of Core PR 11599