Use better variable names, split the function from `ser_to_point(bytes) -> Point` into `ser_to_point(bytes) -> (int, int)]` and `ser_to_python_ecdsa_point(bytes) -> Point`.
This will allow us in future commits to remove some `ecdsa` import in other modules, to keep implementation details contained in ecc.py.
Depends on D16347
This is split out of D16301