Page MenuHomePhabricator

[build] Warn that only libconsensus can be built without boost
ClosedPublic

Authored by Fabien on Jul 4 2019, 15:16.

Details

Summary
This replaces the "configure: error: Could not find a version of the
boost_system library!" message you receive when trying to build without
Boost, with "only libbitcoinconsensus can be built without boost".

Backport of core PR11936
https://github.com/bitcoin/bitcoin/pull/11936/files

Test Plan
./autogen.sh
mkdir build aa cd build
../configure --with-boost=no

Check the output:

configure: error: only libbitcoinconsensus can be built without boost

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.