Page MenuHomePhabricator

Bump debian package compat level to 9
ClosedPublic

Authored by jasonbcox on Thu, Mar 12, 02:48.

Details

Reviewers
Fabien
Group Reviewers
Restricted Project
Commits
rABC4250f970c0fe: Bump debian package compat level to 9
Summary

Compat level 9 is recommended by Debian: https://manpages.debian.org/jessie/debhelper/debhelper.7.en.html#COMPATIBILITY_LEVELS
Also, compat leves 7 and 8 are deprecated, despite that doc not indicating such.

Test Plan

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

jasonbcox created this revision.Thu, Mar 12, 02:48
Herald added a reviewer: Restricted Project. · View Herald TranscriptThu, Mar 12, 02:48
Fabien accepted this revision.Thu, Mar 12, 08:25
Fabien added a subscriber: Fabien.
Fabien added inline comments.
contrib/debian/rules
9 ↗(On Diff #16893)

unrelated ?

This revision is now accepted and ready to land.Thu, Mar 12, 08:25
jasonbcox added inline comments.Thu, Mar 12, 16:30
contrib/debian/rules
9 ↗(On Diff #16893)

Sorry, forgot to mention: See https://manpages.debian.org/jessie/debhelper/debhelper.7.en.html#COMPATIBILITY_LEVELS v7 -> v8 describes this as a necessary change.

This revision was automatically updated to reflect the committed changes.