HomePhabricator

[LINTER] Enforce shellcheck >= 0.7.0

Authored by Fabien on Jun 24 2020, 20:02.

Description

[LINTER] Enforce shellcheck >= 0.7.0

Summary:
The recent changes from D6701 require the --source-path option which
is only available from 0.7.0. Since shellcheck can be download as a
standalone binary this is still easy to install.

Test Plan:

arc lint --everything

Reviewers: #bitcoin_abc, jasonbcox

Reviewed By: #bitcoin_abc, jasonbcox

Subscribers: jasonbcox

Differential Revision: https://reviews.bitcoinabc.org/D6720

Details

Committed
FabienJun 24 2020, 20:58
Pushed
FabienJun 24 2020, 20:58
Reviewer
Restricted Project
Differential Revision
D6720: [LINTER] Enforce shellcheck >= 0.7.0
Parents
rABC4b0c6d74041a: Merge #14051: [Tests] Make combine_logs.py handle multi-line logs
Branches
Unknown
Tags
Unknown