[refactor] add alias for Schnorr signatures and remove size magic number
Summary:
Schnorr signatures repeat as std::array<uint8_t, 64> throughout the
code. this defines them in a single alias and replaces the magic number
with CPubKey::SCHNORR_SIZE
Test Plan:
ninja check-all
Reviewers: #bitcoin_abc, PiRK
Reviewed By: #bitcoin_abc, PiRK
Subscribers: PiRK
Differential Revision: https://reviews.bitcoinabc.org/D9251