for type safety. as long as i'm touching those lines, I also added
auto liberally and const where appropriate
Details
Details
- Reviewers
deadalnix - Group Reviewers
Restricted Project - Commits
- rABC1ca8fd1636b0: [refactor] change orphan txs std::map member to use TxId instead of uint256
ninja check-extended
Diff Detail
Diff Detail
- Repository
- rABC Bitcoin ABC
- Lint
Lint Not Applicable - Unit
Tests Not Applicable
Event Timeline
Comment Actions
addressed comments, added more explicit names, replaced a constructor initialization with list initialization to guard against narrowind conversions, made a TxId function parameter const
src/net_processing.cpp | ||
---|---|---|
1029 ↗ | (On Diff #20516) | TxId is not any longer than auto and make things clearer. |
1131 ↗ | (On Diff #20516) | const TxId randomTxId(rng.rand256()); |
1251 ↗ | (On Diff #20516) | TxId also, orphanId to match naming in the source material. |
1260 ↗ | (On Diff #20516) | revert |
2891 ↗ | (On Diff #20516) | just txid |