Minor improvements to add_nodes
This is a backport of core PR14805 and PR14951.
Since the first one add a feature and the second reverts it, the
remaining is a refactor-only commit that improves the docstring for
add_nodes() and cuts a long line to improve readability:
Depends on D4557.
Reviewers: #bitcoin_abc, deadalnix
Reviewed By: #bitcoin_abc, deadalnix
Differential Revision: https://reviews.bitcoinabc.org/D4559