Add a linter to enfore unit tests file name/boost name match and unicity
Summary:
This linter will warn if:
- The BOOST_FIXTURE_TEST_SUITE name does not match the file name
- The test name is not unique
Also add an entry in the dev notes.
Based on core PR12719 and PR12859
Test Plan:
Should return nothing:
./test/lint/lint-tests.sh
Rename the BOOST_FIXTURE_TEST_SUITE name in
src/wallet/test/wallet_crypto_tests.cpp to crypto_tests.
./test/lint/lint-tests.sh
Check the mismatch and the duplicata are detected
Reviewers: #bitcoin_abc, deadalnix
Reviewed By: #bitcoin_abc, deadalnix
Subscribers: teamcity, schancel
Differential Revision: https://reviews.bitcoinabc.org/D2532