[mining] Rename several CBlockTemplateEntry members for clarity
Summary: Rename variables in order to clarify what these items are associated with for a future change, which will be adding package data. Additionally, add the txSize which will be used in further diffs.
Reviewers: O1 Bitcoin ABC, #bitcoin_abc, deadalnix, jasonbcox
Reviewed By: O1 Bitcoin ABC, #bitcoin_abc, jasonbcox
Differential Revision: https://reviews.bitcoinabc.org/D2862