Rename variables in order to clarify what these items are associated with for a future change, which will be adding package data. Additionally, add the txSize which will be used in further diffs.
- Group Reviewers
Restricted Owners Package (Owns No Changed Paths) Restricted Project
- rABCcebcb34c93c0: [mining] Rename several CBlockTemplateEntry members for clarity
|30 ↗||(On Diff #8224)|
Which code below? There is no code below that assumes these are negative. If you're talking about:
pblocktemplate->entries.emplace_back(CTransactionRef(), -SATOSHI, 0, -1);
That's because they're supposed to be out of bounds.
|206 ↗||(On Diff #8224)|
These original entries predate anything I've done, and the coinbase transaction is discarded in getblocktemplate with only fees being returned. The mining pool software is expected to fill in the details within the 1000 bytes of reserved space.
When the generate rpc is called on regtest the IncramentExtraNonce function *does* use the coinbase, but these fields are also not used.