Page MenuHomePhabricator

Renamed TestBuilder.Push( string hex ) to .PushHex( string hex )
AbandonedPublic

Authored by nakihito on Jan 20 2019, 23:05.

Details

Reviewers
jasonbcox
deadalnix
Group Reviewers
Restricted Owners Package(Owns No Changed Paths)
Restricted Project
Summary

Begins work on T393. Renamed TestBuilder's Push( string hex ) to PushHex( string hex ).

Test Plan

make check

Diff Detail

Repository
rABC Bitcoin ABC
Branch
CategorizingPushes
Lint
Lint OK
Unit
No Unit Test Coverage
Build Status
Buildable 4598
Build 7259: Bitcoin ABC Buildbot (legacy)
Build 7258: arc lint + arc unit

Event Timeline

nakihito created this revision.Jan 20 2019, 23:05
Owners added a reviewer: Restricted Owners Package.Jan 20 2019, 23:05
Herald added a reviewer: Restricted Project. · View Herald TranscriptJan 20 2019, 23:05
Herald added a subscriber: schancel. · View Herald Transcript

I don't understand what this task is about. What is inconsistent ? Why is this naming more consistent ? Who's going to maintain that test going forward ?

My understanding is that the ticket is addressing a code readability issue. You want it to be easier to identify what version of Push() is being used by renaming the overloaded functions based on the argument the function takes. However, I've just been informed that there is an issue of code ownership with these types of changes so I'll close this diff.

nakihito abandoned this revision.Jan 20 2019, 23:34