Page MenuHomePhabricator

nakihito (Nico)
User

Projects

User does not belong to any projects.

User Details

User Since
Jul 22 2018, 17:49 (51 w, 5 d)

Recent Activity

Today

nakihito requested review of D3695: Merge #11133: Document assumptions that are beoing made to avoid division by zero.

We removed TxConfirmStats::removeTx() in policy/fees.cpp where there would have been a change.
qt/coincontroldialog.cpp was changed here to reflect the current state of Core: https://reviews.bitcoinabc.org/D3233#change-MdfjIvPLq5Hf

Fri, Jul 19, 17:44
nakihito requested review of D3696: Merge #10036: Fix init README format to render correctly on github.
Fri, Jul 19, 17:34
nakihito requested review of D3697: Merge #11714: [tests] Test that mempool rejects coinbase transactions.
Fri, Jul 19, 17:34
nakihito updated the test plan for D3689: Merge #11293: Deduplicate CMerkleBlock construction code, add test coverage.
Fri, Jul 19, 01:06
nakihito updated the test plan for D3697: Merge #11714: [tests] Test that mempool rejects coinbase transactions.
Fri, Jul 19, 01:06
nakihito added inline comments to D3697: Merge #11714: [tests] Test that mempool rejects coinbase transactions.
Fri, Jul 19, 01:05
nakihito planned changes to D3697: Merge #11714: [tests] Test that mempool rejects coinbase transactions.
Fri, Jul 19, 01:04
nakihito created D3697: Merge #11714: [tests] Test that mempool rejects coinbase transactions.
Fri, Jul 19, 01:04

Yesterday

nakihito planned changes to D3696: Merge #10036: Fix init README format to render correctly on github.
Thu, Jul 18, 21:40
nakihito created D3696: Merge #10036: Fix init README format to render correctly on github.
Thu, Jul 18, 21:39
nakihito planned changes to D3695: Merge #11133: Document assumptions that are beoing made to avoid division by zero.
Thu, Jul 18, 21:34
nakihito created D3695: Merge #11133: Document assumptions that are beoing made to avoid division by zero.
Thu, Jul 18, 21:34
nakihito updated the diff for D3689: Merge #11293: Deduplicate CMerkleBlock construction code, add test coverage.

Added CMake.

Thu, Jul 18, 18:05

Wed, Jul 17

nakihito created D3689: Merge #11293: Deduplicate CMerkleBlock construction code, add test coverage.
Wed, Jul 17, 20:51

Tue, Jul 16

nakihito created D3685: Merge #11495: [trivial] Make namespace explicit for is_regular_file.
Tue, Jul 16, 23:34
nakihito accepted D3587: [3 of 5] Move CDiskBlockPos from chain to flatfile..
Tue, Jul 16, 23:09
nakihito created D3684: Merge #11626: rpc: Make `logging` RPC public.
Tue, Jul 16, 22:51
nakihito updated the summary of D3464: [rpc] Add logging RPC.
Tue, Jul 16, 22:35
nakihito updated the diff for D3464: [rpc] Add logging RPC.

Removed PR11626. It will be made into its own diff.

Tue, Jul 16, 22:35
nakihito planned changes to D3464: [rpc] Add logging RPC.
Tue, Jul 16, 22:18

Mon, Jul 15

nakihito created D3677: Error messages in LoadBlockIndexGuts() use __func__ instead of hardcoding function name..
Mon, Jul 15, 23:09
nakihito added inline comments to D3656: Merge #10793: Changing &var[0] to var.data().
Mon, Jul 15, 22:58
nakihito accepted D3619: Merge #9544: [trivial] Add end of namespace comments. Improve consistency..
Mon, Jul 15, 22:39
nakihito accepted D3655: Add virtual transaction size to the transaction description in Qt.
Mon, Jul 15, 22:33
nakihito added a comment to D3671: Merge #10777: [tests] Avoid redundant assignments. Remove unused variables.

What's up with sighash_tests.cpp?

Mon, Jul 15, 22:29
nakihito updated the summary of D3464: [rpc] Add logging RPC.
Mon, Jul 15, 18:19
nakihito updated the diff for D3464: [rpc] Add logging RPC.

Added PR11626 to make the logging rpc public.

Mon, Jul 15, 18:18
nakihito requested review of D3656: Merge #10793: Changing &var[0] to var.data().
Mon, Jul 15, 18:16
nakihito requested review of D3660: Merge #11330: Trivial: Fix comments for DEFAULT_WHITELIST[FORCE]RELAY.
Mon, Jul 15, 17:18
nakihito requested review of D3671: Merge #10777: [tests] Avoid redundant assignments. Remove unused variables.
Mon, Jul 15, 17:17
nakihito requested review of D3658: Merge #10845: Remove unreachable code.
Mon, Jul 15, 17:14
nakihito requested review of D3659: Merge #11469: fix typo in comment of chain.cpp.
Mon, Jul 15, 17:12

Fri, Jul 12

nakihito planned changes to D3671: Merge #10777: [tests] Avoid redundant assignments. Remove unused variables.
Fri, Jul 12, 18:42
nakihito created D3671: Merge #10777: [tests] Avoid redundant assignments. Remove unused variables.
Fri, Jul 12, 18:42
nakihito added a comment to D3667: Version number bumped to 0.19.11.

[Errno 28] No space left on device

Fri, Jul 12, 18:41
nakihito created D3667: Version number bumped to 0.19.11.
Fri, Jul 12, 18:00

Thu, Jul 11

nakihito planned changes to D3660: Merge #11330: Trivial: Fix comments for DEFAULT_WHITELIST[FORCE]RELAY.
Thu, Jul 11, 22:34
nakihito created D3660: Merge #11330: Trivial: Fix comments for DEFAULT_WHITELIST[FORCE]RELAY.
Thu, Jul 11, 22:34
nakihito planned changes to D3659: Merge #11469: fix typo in comment of chain.cpp.
Thu, Jul 11, 22:29
nakihito planned changes to D3658: Merge #10845: Remove unreachable code.
Thu, Jul 11, 22:29
nakihito created D3659: Merge #11469: fix typo in comment of chain.cpp.
Thu, Jul 11, 22:23
nakihito created D3658: Merge #10845: Remove unreachable code.
Thu, Jul 11, 22:12
nakihito planned changes to D3656: Merge #10793: Changing &var[0] to var.data().
Thu, Jul 11, 21:25
nakihito created D3656: Merge #10793: Changing &var[0] to var.data().
Thu, Jul 11, 21:11
nakihito abandoned D3640: Merge #10481: Decodehextx scripts sanity check.
Thu, Jul 11, 00:16

Wed, Jul 10

nakihito requested review of D3619: Merge #9544: [trivial] Add end of namespace comments. Improve consistency..

base58.cpp change wes made in D624 and then the code was moved to a different file in D3577.
The majority of other changes were made in D873.

Wed, Jul 10, 22:06
nakihito created D3640: Merge #10481: Decodehextx scripts sanity check.
Wed, Jul 10, 21:45
nakihito updated the diff for D3623: Merge #10728: fix typo in help text for removeprunedfunds.

Allowed linter to relayout help string.

Wed, Jul 10, 00:26

Tue, Jul 9

nakihito created D3623: Merge #10728: fix typo in help text for removeprunedfunds.
Tue, Jul 9, 23:53
nakihito updated the diff for D3620: Merge #10581: Simplify return values of GetCoin/HaveCoin(InCache).

Fixed comment formatting.

Tue, Jul 9, 23:32
nakihito created D3622: Merge #10685: Clarify CCoinsViewMemPool documentation..
Tue, Jul 9, 23:17
nakihito created D3621: Merge #10684: Remove no longer used mempool.exists(outpoint).
Tue, Jul 9, 22:40
nakihito added a comment to D3620: Merge #10581: Simplify return values of GetCoin/HaveCoin(InCache).

GetCoin() in txmempool.h was changed here: https://reviews.bitcoinabc.org/D763#change-X7xlaclCBwBo

Tue, Jul 9, 21:09
nakihito created D3620: Merge #10581: Simplify return values of GetCoin/HaveCoin(InCache).
Tue, Jul 9, 21:07
nakihito added a comment to D3587: [3 of 5] Move CDiskBlockPos from chain to flatfile..

Note: alternatively we could keep the split and rename diskblockpos.h to flatfilepos.h and put the ToString() implementation in a .cpp file also, or ...?
I'm not totally sure if it's worth splitting up the two, the main thing seems to have been getting it out of chain.h.

Tue, Jul 9, 20:43
nakihito planned changes to D3619: Merge #9544: [trivial] Add end of namespace comments. Improve consistency..
Tue, Jul 9, 19:49
nakihito created D3619: Merge #9544: [trivial] Add end of namespace comments. Improve consistency..
Tue, Jul 9, 19:49
nakihito requested review of D3599: Merge #10191: [trivial] Rename unused RPC arguments 'dummy'.
Tue, Jul 9, 19:15

Mon, Jul 8

nakihito created D3602: Merge #10559: Change semantics of HaveCoinInCache to match HaveCoin.
Mon, Jul 8, 23:10
nakihito created D3600: Merge #10627: fixed listunspent rpc convert parameter.
Mon, Jul 8, 22:05
nakihito planned changes to D3599: Merge #10191: [trivial] Rename unused RPC arguments 'dummy'.
Mon, Jul 8, 20:47
nakihito created D3599: Merge #10191: [trivial] Rename unused RPC arguments 'dummy'.
Mon, Jul 8, 20:47
nakihito created D3597: Merge #10626: doc: Remove outdated minrelaytxfee comment.
Mon, Jul 8, 20:31
nakihito updated the diff for D3464: [rpc] Add logging RPC.

Changed logging() to static.

Mon, Jul 8, 17:01
nakihito updated the diff for D3530: Make various functions in src/test/ static.

Rebased due to some file names being changed in a different patch.

Mon, Jul 8, 16:27

Sat, Jul 6

nakihito updated the diff for D3569: Merge #10530: Fix invalid instantiation and possibly unsafe accesses of array in class base_uint<BITS>.

Changed (uint32_t)-1 to std::numeric_limits<uint32_t>::max().

Sat, Jul 6, 06:44

Fri, Jul 5

nakihito added a comment to D3542: Merge #10537: Few Minor per-utxo assert-semantics re-adds and tweak.
In D3542#84072, @Fabien wrote:

The changes to consensus/tx_verify.cpp need to be backported. It's not in our codebase.

Fri, Jul 5, 23:11
nakihito created D3569: Merge #10530: Fix invalid instantiation and possibly unsafe accesses of array in class base_uint<BITS>.
Fri, Jul 5, 20:25
nakihito requested review of D3542: Merge #10537: Few Minor per-utxo assert-semantics re-adds and tweak.

coins.cpp changes were previously made here: https://reviews.bitcoinabc.org/D470
consensus/tx_verify.cpp changes were made here: https://reviews.bitcoinabc.org/D1739 (note: GetTransactionSigOpCost() was never added)
validation.cpp changes made here: https://reviews.bitcoinabc.org/D1479 and here: https://reviews.bitcoinabc.org/D471#change-8J68DPC7df8b

Fri, Jul 5, 18:44
nakihito requested review of D3526: Make printchunk() in support/lockedpool.cpp static.

Changed title to better describe changes as requested by @deadalnix.

Fri, Jul 5, 17:57
nakihito requested review of D3530: Make various functions in src/test/ static.

Changed title to better describe changes as requested by @deadalnix.

Fri, Jul 5, 17:56
nakihito requested review of D3505: Merge #10347: Use range-based for loops (C++11) when looping over vector elements.
Fri, Jul 5, 17:55
nakihito updated the test plan for D3464: [rpc] Add logging RPC.
Fri, Jul 5, 17:36
nakihito updated the diff for D3464: [rpc] Add logging RPC.

Fixed comment.

Fri, Jul 5, 17:31

Wed, Jul 3

nakihito retitled D3530: Make various functions in src/test/ static from Merge #13163: Make it clear which functions that are intended to be translation unit local (src/test/) to Make various functions in src/test/ static.
Wed, Jul 3, 22:27
nakihito retitled D3526: Make printchunk() in support/lockedpool.cpp static from Merge #13163: Make it clear which functions that are intended to be translation unit local (support/lockedpool.cpp) to Make printchunk() in support/lockedpool.cpp static.
Wed, Jul 3, 22:12
nakihito planned changes to D3542: Merge #10537: Few Minor per-utxo assert-semantics re-adds and tweak.
Wed, Jul 3, 21:43
nakihito created D3542: Merge #10537: Few Minor per-utxo assert-semantics re-adds and tweak.
Wed, Jul 3, 21:43
nakihito created D3541: Merge #10313: [Consensus] Add constant for maximum stack size.
Wed, Jul 3, 19:39
nakihito updated the test plan for D3464: [rpc] Add logging RPC.
Wed, Jul 3, 18:56
nakihito updated the summary of D3464: [rpc] Add logging RPC.
Wed, Jul 3, 18:36
nakihito planned changes to D3464: [rpc] Add logging RPC.
Wed, Jul 3, 18:24
nakihito updated the diff for D3464: [rpc] Add logging RPC.

Added libevent filter, but had to pull the updated code from PR12954 along with some other changes to make everything fit together.

Wed, Jul 3, 18:24
nakihito planned changes to D3505: Merge #10347: Use range-based for loops (C++11) when looping over vector elements.
Wed, Jul 3, 00:13
nakihito updated the diff for D3505: Merge #10347: Use range-based for loops (C++11) when looping over vector elements.

Fixed nits.

Wed, Jul 3, 00:13

Tue, Jul 2

nakihito abandoned D3293: Merge #13163: Make it clear which functions that are intended to be translation unit local.

This has been broken into smaller parts. See D3530, D3526, D3525, D3524, D3523, D3522, D3512, D3510.

Tue, Jul 2, 23:49
nakihito updated the diff for D3530: Make various functions in src/test/ static.

Reverted accidental variable type changes.

Tue, Jul 2, 22:42
nakihito planned changes to D3530: Make various functions in src/test/ static.
Tue, Jul 2, 22:28
nakihito created D3530: Make various functions in src/test/ static.
Tue, Jul 2, 22:27
nakihito requested review of D3526: Make printchunk() in support/lockedpool.cpp static.
Tue, Jul 2, 22:24
nakihito abandoned D3529: Merge #13163: Make it clear which functions that are intended to be translation unit local (test/uint256_tests.cpp).
Tue, Jul 2, 22:23
nakihito planned changes to D3526: Make printchunk() in support/lockedpool.cpp static.
Tue, Jul 2, 22:08
nakihito planned changes to D3529: Merge #13163: Make it clear which functions that are intended to be translation unit local (test/uint256_tests.cpp).
Tue, Jul 2, 22:07
nakihito updated the summary of D3526: Make printchunk() in support/lockedpool.cpp static.
Tue, Jul 2, 22:07
nakihito created D3529: Merge #13163: Make it clear which functions that are intended to be translation unit local (test/uint256_tests.cpp).
Tue, Jul 2, 21:48
nakihito created D3526: Make printchunk() in support/lockedpool.cpp static.
Tue, Jul 2, 19:10
nakihito created D3525: Merge #13163: Make it clear which functions that are intended to be translation unit local (bitcoin-cli.cpp).
Tue, Jul 2, 18:24
nakihito created D3524: Merge #13163: Make it clear which functions that are intended to be translation unit local (bitcoind.cpp).
Tue, Jul 2, 18:08
nakihito created D3523: Merge #13163: Make it clear which functions that are intended to be translation unit local (rpc/rawtransaction.cpp).
Tue, Jul 2, 18:03
nakihito created D3522: Merge #13163: Make it clear which functions that are intended to be translation unit local (init.cpp).
Tue, Jul 2, 17:29