C++11 initializer lists are more elegant and easier to maintain and read. So I removed all usages of boost::assign::list_of in favor of them. Note that some of these files have never been linted before so they may have extra lint formatting changes too.
make check, rpc-tests.py
A few changes, but that looks nice already.
Try to put these back in one string and see what clang format does.
Use C++ style constructor.
It'll be much more readable.
I think you can do
But I haven't followed the latest C++ crazyness. Also, put the comment on the line before the code. It'll get better formatting it also make blame clearer.
C++ style constructor instead of C style casts.
Is the std::string really necessary ?
Thanks for the feedback. I just did a quick pass to change it over -- but your readability feedback is good. I'll change it and update the revision.
Yeah, that will look better. Good point. Will-do.
Yeah you can and it will be much more readable, good point.
No, it's not. Maybe it was for boos but for this initializer list it isn't. I'll change it -- it will be more readable. I don't think the casts are necessary either.
|205 ↗||(On Diff #1157)|
Looks CCheckpointData would deserve a constructor of it's own. Having objects being just bags of data that anyone can manipulate is not good. But maybe that's out of the scope here.
Nice, it doesn't looks like it is necessary at all.