Page MenuHomePhabricator

build: set minimum supported macOS to 10.12
ClosedPublic

Authored by Fabien on Thu, Mar 19, 15:49.

Details

Summary
Reasoning:

    10.10 has been unsupported since July 2017 (~3 years at v0.20.0
release)
    10.11 has been unsupported since July 2018 (~2 years at v0.20.0
release)
    macOS users are consistent at upgrading to new releases.
    Qt 5.12 LTS only supports macOS > 10.12. As long as we're supporting
macOS < 10.12 we would not be able to bump Qt in depends to 5.12 for the
v0.20.0 release.

Backport of core PR17550.

Test Plan

Run the OSX Gitian build.
Run the binary on 10.12 and 10.15.

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Fabien created this revision.Thu, Mar 19, 15:49
Herald added a reviewer: Restricted Project. · View Herald TranscriptThu, Mar 19, 15:49
teamcity edited the summary of this revision. (Show Details)Thu, Mar 19, 15:49

[Bot Message]
One or more PR numbers were detected in the summary.
Links to those PRs have been inserted into the summary for reference.

deadalnix accepted this revision.Thu, Mar 19, 17:31
This revision is now accepted and ready to land.Thu, Mar 19, 17:31
This revision was automatically updated to reflect the committed changes.