Page MenuHomePhabricator

[LINTER] Enforce mypy >= 0.780
ClosedPublic

Authored by Fabien on Tue, Jul 6, 10:04.

Details

Reviewers
PiRK
Group Reviewers
Restricted Project
Commits
rABCcff75003c4fc: [LINTER] Enforce mypy >= 0.780
Summary

Found during testing, previous versions are buggy in several ways:

  • They don't follow dependencies the same and print the issues from other files
  • They have trouble handling python 3.6 type annotation syntax
Test Plan

Read and try the instructions (tested on Debian 10 and Ubuntu Focal).

arc lint --everything

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Lint Not Applicable
Unit
Tests Not Applicable