Currently, we use the full transaction size for a minimum fee calculation.
This commit changes the behavior to charge for the additional (minimum) of
179 bytes it would take to spend any newly created outputs.
Details
Details
make check && ./test/functional/test_runner.py --extended
Diff Detail
Diff Detail
- Repository
- rABC Bitcoin ABC
- Branch
- arcpatch-D1486
- Lint
Lint Passed - Unit
No Test Coverage - Build Status
Buildable 2762 Build 3634: Bitcoin ABC Buildbot (legacy) Build 3633: arc lint + arc unit
Event Timeline
Comment Actions
Everything else looks good. I assume the reason you aren't merging in D1480 is that that particular change fails tests and may be it's own can of worms, yes?
src/test/transaction_tests.cpp | ||
---|---|---|
768–769 ↗ | (On Diff #4084) | I'm finding this hard to read with the short names. Please do (or similar): |
src/txmempool.cpp | ||
---|---|---|
897 ↗ | (On Diff #4084) | The previous GetTxSize() cached the size internally to the mempool entry. This does not. I am curious as to if I should make the mempool entry cache this data. |
src/wallet/wallet.cpp | ||
---|---|---|
2921 | remove second space after // the |
src/primitives/transaction.cpp | ||
---|---|---|
114 ↗ | (On Diff #4420) | change -> charge? |