HomePhabricator

[backport#16658] validation: Rename CheckInputs to CheckInputScripts

Description

[backport#16658] validation: Rename CheckInputs to CheckInputScripts

Summary:
3bd8db80d8d335ab63ece4f110b0fadd562e80b7 [validation] fix comments in CheckInputScripts() (John Newbery)
6f6465cefcd599c89c00f7b51f42a4b87a5ffb0b scripted-diff: [validation] Rename CheckInputs to CheckInputScripts (John Newbery)

Pull request description:

CheckInputs() used to check no double spends, scripts & sigs and amounts. Since
832e074, the double spend and amount checks
have been moved to CheckTxInputs(), and CheckInputs() now just validates
input scripts. Rename the function to CheckInputScripts().

Also fix incorrect comments.

Backport of Core PR16658

Test Plan:

ninja all check check-functional

Reviewers: #bitcoin_abc, deadalnix

Reviewed By: #bitcoin_abc, deadalnix

Subscribers: deadalnix

Differential Revision: https://reviews.bitcoinabc.org/D8762

Details

Provenance
MarcoFalke <falke.marco@gmail.com>Authored on Jan 2 2020, 16:08
majcostaCommitted on Wed, Jan 13, 14:44
majcostaPushed on Wed, Jan 13, 14:44
Reviewer
Restricted Project
Differential Revision
D8762: [backport#16658] validation: Rename CheckInputs to CheckInputScripts
Parents
rABC78de14facc83: test: listsinceblock block height checks
Branches
Unknown
Tags
Unknown