Page MenuHomePhabricator

[backport#16658] validation: Rename CheckInputs to CheckInputScripts

Authored by majcosta on Tue, Dec 29, 19:54.



3bd8db80d8d335ab63ece4f110b0fadd562e80b7 [validation] fix comments in CheckInputScripts() (John Newbery)
6f6465cefcd599c89c00f7b51f42a4b87a5ffb0b scripted-diff: [validation] Rename CheckInputs to CheckInputScripts (John Newbery)

Pull request description:

CheckInputs() used to check no double spends, scripts & sigs and amounts. Since
832e074, the double spend and amount checks
have been moved to CheckTxInputs(), and CheckInputs() now just validates
input scripts. Rename the function to CheckInputScripts().

Also fix incorrect comments.

Backport of Core PR16658

Test Plan
ninja all check check-functional

Diff Detail

rABC Bitcoin ABC
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

deadalnix requested changes to this revision.Tue, Dec 29, 23:26
deadalnix added a subscriber: deadalnix.

What about the integration tests?

This revision now requires changes to proceed.Tue, Dec 29, 23:26

it looks like D3878 and D3875 diverged from Core so that the tests don't rely on whether "CheckInputs" or "CheckInputScripts" gets printed to the debug log

This revision is now accepted and ready to land.Wed, Jan 13, 14:21