Page MenuHomePhabricator

Create a typedef for handling mapDeltas in the mempool.
ClosedPublic

Authored by schancel on May 8 2018, 05:01.

Details

Summary

This commit creates a typedef for handling mapDeltas in the mempool.
This exists to allow easy changes to the base type going forward.

Test Plan

make check

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

deadalnix added inline comments.
src/txmempool.h
562 ↗(On Diff #3814)

WHy the rename ? Are going to have all the field named m_somethingnow ?

src/txmempool.h
562 ↗(On Diff #3814)

That's what we agreed in the style guide.

src/txmempool.h
562 ↗(On Diff #3814)

That's ugly and doesn't match existing style.

src/txmempool.h
562 ↗(On Diff #3814)

The goal of a style guide is to make sure the codebase stay uniform, it's clearly not working here.

src/txmempool.h
562 ↗(On Diff #3814)

The codebase is completely inconsistent right now. I proposed a standard, and it was accepted by people who cared.

If you want to use a different standard you need to be vocal on the documentation itself. This was a middle ground that we all agreed to so we could know when the code was referring to a global, local, or member variable.

deadalnix requested changes to this revision.Jun 18 2018, 23:58

Can you remove the m_ from m_txModifiers ? Beside that, it's all good.

This revision now requires changes to proceed.Jun 18 2018, 23:58

Change name of parameter back to mapDeltas

This revision is now accepted and ready to land.Jul 14 2018, 23:55

Rebase to see if test is fixed?

This revision was automatically updated to reflect the committed changes.