Page MenuHomePhabricator

release: require macOS 10.10+
ClosedPublic

Authored by Fabien on Aug 20 2019, 12:12.

Details

Summary

Qt 5.9.6 is incompatible with macOS < 10.10

Backport of core PR13617
https://github.com/bitcoin/bitcoin/pull/13617/files

Depends on D3912, D3913 and D3917.

Test Plan

Run a native build with autotools and cmake.
Cross build with autotools and cmake.
Run the gitian build.

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Fabien created this revision.Aug 20 2019, 12:12
Herald added a reviewer: Restricted Project. · View Herald TranscriptAug 20 2019, 12:12
Fabien planned changes to this revision.Aug 20 2019, 12:13

Will request for review after the Gitian and native builds have been successful.

Fabien requested review of this revision.Aug 20 2019, 15:57

Ready to review.

jasonbcox accepted this revision.Aug 20 2019, 19:07
This revision is now accepted and ready to land.Aug 20 2019, 19:07
This revision was automatically updated to reflect the committed changes.