Page MenuHomePhabricator

scripted-diff: Rename sync_blocks to send_blocks

Authored by Fabien on May 20 2020, 08:48.


Summary avoid name collisions and confusion

FILE_LIST=$(git grep -l 'def sync_blocks' ./test/functional/*.py)
sed -i -e 's/def sync_blocks/def send_blocks/g'   $FILE_LIST
sed -i -e 's/self.sync_blocks/self.send_blocks/g' $FILE_LIST

Partial backport of core PR15773:

Test Plan
./test/functional/ feature_block feature_csv_activation

Diff Detail

rABC Bitcoin ABC
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Fabien created this revision.May 20 2020, 08:48
Herald added a reviewer: Restricted Project. · View Herald TranscriptMay 20 2020, 08:48
Fabien requested review of this revision.May 20 2020, 08:48
teamcity edited the summary of this revision. (Show Details)May 20 2020, 08:48

[Bot Message]
One or more PR numbers were detected in the summary.
Links to those PRs have been inserted into the summary for reference.

deadalnix requested changes to this revision.May 20 2020, 11:42
deadalnix added a subscriber: deadalnix.

I think there are naked calls to sync_block remaining. Can you fix this first?

The command in the description were fubared, I had to fix them. Did you run them?

This revision now requires changes to proceed.May 20 2020, 11:42
deadalnix accepted this revision.May 20 2020, 11:51

It's done in D6153, nevermind.

This revision is now accepted and ready to land.May 20 2020, 11:51
This revision was automatically updated to reflect the committed changes.