Unittests.
Details
Details
- Reviewers
deadalnix - Group Reviewers
Restricted Project - Commits
- rSTAGINGeb096c1f0a11: Implement {Encode,Decode}Destination without CBitcoinAddress
rABCeb096c1f0a11: Implement {Encode,Decode}Destination without CBitcoinAddress
Diff Detail
Diff Detail
- Repository
- rABC Bitcoin ABC
- Branch
- arcpatch-D624
- Lint
Lint Passed - Unit
No Test Coverage - Build Status
Buildable 1098 Build 1098: arc lint + arc unit
Event Timeline
src/base58.cpp | ||
---|---|---|
220 ↗ | (On Diff #1604) | uint8_t |
227 ↗ | (On Diff #1604) | dito |
238 ↗ | (On Diff #1604) | uint8_t |
240 ↗ | (On Diff #1604) | I'd prefers to do if (!DecodeBase58Check(str, data)) { return CNoDestination(); } // Do the other stuffs.... So that we don't nest deeper and deeper. |
242 ↗ | (On Diff #1604) | dito |
250 ↗ | (On Diff #1604) | dito |
261 ↗ | (On Diff #1604) | Could you add an extra line to make the separation between the namespace and the function clearer ? |
src/base58.cpp | ||
---|---|---|
240 ↗ | (On Diff #1604) | I do too, but I generally don't change too much when cherry picking works by others. I'll fix this one though. |