Page MenuHomePhabricator

Merge #10706: Improve wallet fee logic and fix GUI bugs

Authored by jasonbcox on Mar 8 2019, 00:32.



11590d3 Properly bound check conf_target in wallet RPC calls (Alex Morcos)
fd29d3d Remove checking of mempool min fee from estimateSmartFee. (Alex Morcos)
2fffaa9 Make QT fee displays use GetMinimumFee instead of estimateSmartFee (Alex Morcos)
1983ca6 Use CoinControl to pass custom fee setting from QT. (Alex Morcos)
03ee701 Refactor to use CoinControl in GetMinimumFee and FeeBumper (Alex Morcos)
ecd81df Make CoinControl a required argument to CreateTransaction (Alex Morcos)

Pull request description:

This builds on #10589  (first 5 commits from that PR, last 5 commits are new)

The first couple commits refactor to use the CCoinControl class to pass fee calculation parameters around.

This allows for fixing the buggy interaction in QT between the global payTxFee which can be modified by the RPC call settxfee or temporarily modified by the QT custom fee settings.  Before these changes the GUI could sometimes send a transaction with a recently set payTxFee and not respect the settings displayed in the GUI.   After these changes, using the GUI does not involve the global transaction confirm target or payTxFee.

The prospective fee displays in the smart fee slider and the coin control dialog are changed to use the fee calculation from GetMinimumFee, this simplifies the code and makes them slightly more correct in edge cases.

Maxing the fee calculation with the mempool min fee is move from estimateSmartFee to GetMinimumFee.

This fixes a long standing bug, and should be tagged for 0.15 as it is holding up finalizing the estimatesmartfee RPC API before release.

Tree-SHA512: 4d36a1bd5934aa62f3806d380fcafbef73e9fe5bdf190fc5259a3e3a13349e5ce796e50e7068c46dc630ccf56d061bce5804f0bfe2e082bb01ca725b63efd4c1

Backport of Core PR10706 minus RBF and other unused codepaths.
Completes T521

Co-authored-by: Jason B. Cox <>

Test Plan
make check
ninja check
bitcoin-qt # for sanity

Diff Detail

rABC Bitcoin ABC
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Fabien requested changes to this revision.Mar 8 2019, 17:23

I think there is a backport missing in rpcwallet.cpp for the fundrawtransaction RPC:

729 ↗(On Diff #7649)

I don't think this is actually possible to get estimateFee() to return a negative fee rate ?
If so this branch can be removed, as well as labelSmartfee2.
Anyway this is out of scope for this backport.

27 ↗(On Diff #7649)

This can likely be removed

38 ↗(On Diff #7649)


733 ↗(On Diff #7649)

Why changing the name from the original PR ?

This revision now requires changes to proceed.Mar 8 2019, 17:23
729 ↗(On Diff #7649)

That is correct, txmempool::estimateFee can't return a negative value. Once these backports are more or less up-to-date, I can go in and mop stuff like this up.

27 ↗(On Diff #7649)

I'm leaving it in for now to reduce merge conflicts, but yes it can be removed as it's effectively unused (similar to labelSmartFee).

733 ↗(On Diff #7649)

I don't recall doing this. Will fix.

In D2673#62455, @Fabien wrote:

I think there is a backport missing in rpcwallet.cpp for the fundrawtransaction RPC:

I don't think this has a direct impact on this diff, but I will go ahead and backport it in order: T546

I think this will allow to backport some more change in the fundrawtransaction RPC. In the original PR these changes are in located rpcwallet.cpp starting from line 2732.

2754 ↗(On Diff #7649)

Also this is not part of the original PR and shouldn't be needed after PR9672

Fixed missing lines from the original backport in rpcwallet.cpp

This revision is now accepted and ready to land.Mar 11 2019, 17:27
This revision was automatically updated to reflect the committed changes.