miner: Remove mentions of 'package' in names
We no longer have the concept of packages in the block generation code. This commit renames the following: - `TestPackage` to `TestTx`, plus rename its args - `addPackageFrac` to `addTxsFrac` - `addPackageTxs` to `addTxs` Also updated comments.
Note that TestTx has been renamed to TestTxFits. We already have a poorly named CheckTx method here, no need for another layer of confusion.
miner: Add fPrintPriority member variable
There is no reason to keep checking this arg each time we add a tx. Best to cache it once at class construction. This saves cycles.
Port of bchn#1118.
Depends on D13121.