Page MenuHomePhabricator

Rename monolith_opcodes.cpp to opcode_tests.cpp

Authored by jasonbcox on Jul 25 2018, 10:27.


Group Reviewers
Restricted Project

The monolith_opcodes.cpp file contains tests for the opcodes that were re-enabled for the Monolith upgrade (May 2018).

In order to add tests to this file for future changes to opcodes, it should be renamed to be independent of the Monolith upgrade.

This change renames the file, and the test suite included in it, to opcode_tests.

Test Plan

To confirm that all tests still pass: make check
To confirm that the tests have been renamed and have not been lost: src/test/test_bitcoin --run_test=opcode_tests

Diff Detail

Lint OK
No Unit Test Coverage
Build Status
Buildable 2936
Build 3974: arc lint + arc unit

Event Timeline

danconnolly retitled this revision from rename monolith_opcodes tests to opcode_tests to Rename monolith_opcodes.cpp to opcode_tests.cpp.Jul 28 2018, 11:04
danconnolly edited the summary of this revision. (Show Details)
danconnolly edited the test plan for this revision. (Show Details)
danconnolly edited the test plan for this revision. (Show Details)
danconnolly added a reviewer: Restricted Project.Jul 28 2018, 12:49
This revision is now accepted and ready to land.Aug 6 2018, 15:50
jasonbcox edited reviewers, added: danconnolly; removed: jasonbcox.
This revision now requires review to proceed.Sep 20 2018, 21:17
schancel requested changes to this revision.Sep 20 2018, 21:33
schancel added a subscriber: schancel.

We want to keep these tests for different HFs in separate files.

This revision now requires changes to proceed.Sep 20 2018, 21:33