I have no sense of scale for this value. Is order == # of dependencies? If so, why not just call it pacakageDependencies?
The note is the only reference to double counting. There needs to be an explanation in this comment for this behavior otherwise the (>= real size) comments mean nothing without that context.
Also: There should be a comment in this diff or the summary with a link to the other diff where this is used so reviewers can appropriate evaluate it. Otherwise we're just looking at variable names with no context.