Page MenuHomePhabricator

[CMAKE] Move the functional tests junit reports to the test/junit dir
ClosedPublic

Authored by Fabien on Wed, Jul 22, 15:22.

Details

Summary

The goal is to have a single output directory for all the junit reports.
The report directory is now always created when any test target is run.

Depends on D7002.

Test Plan
ninja check-functional

Check the report is generated to the test/junit directory.

Diff Detail

Repository
rABC Bitcoin ABC
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Fabien created this revision.Wed, Jul 22, 15:22
Herald added a reviewer: Restricted Project. · View Herald TranscriptWed, Jul 22, 15:22
Fabien requested review of this revision.Wed, Jul 22, 15:22
deadalnix requested changes to this revision.Wed, Jul 22, 23:13
deadalnix added a subscriber: deadalnix.
deadalnix added inline comments.
cmake/modules/TestSuite.cmake
14 ↗(On Diff #22425)

No need for a folder.

test/CMakeLists.txt
59 ↗(On Diff #22425)

test/junit ?

Not a big fan of dumping everythign at the root.

Also, make sure this is geting clearer on ninja clean

This revision now requires changes to proceed.Wed, Jul 22, 23:13
Fabien planned changes to this revision.Thu, Jul 23, 07:07
Fabien added inline comments.
cmake/modules/TestSuite.cmake
14 ↗(On Diff #22425)

The whole point of this diff is to move toward a single directory for all the junit files so the CI knows where to look and new files as needed with no further configuration.

Fabien edited the test plan for this revision. (Show Details)Thu, Jul 23, 07:41
Fabien retitled this revision from [CMAKE] Move the functional tests junit reports to the junit_reports dir to [CMAKE] Move the functional tests junit reports to the test/junit dir.Thu, Jul 23, 07:47
Fabien updated this revision to Diff 22454.Thu, Jul 23, 07:48

Rebase on top of updated D7002 to address feedbacks:

  • The report directory moved to test/junit
  • The report directory is cleaned by the clean target
deadalnix accepted this revision.Thu, Jul 23, 12:07
This revision is now accepted and ready to land.Thu, Jul 23, 12:07
Fabien updated this revision to Diff 22501.Fri, Jul 24, 19:40

Rebase and remove junit_ prefix to match the naming convention from D7002.

Fabien planned changes to this revision.Mon, Jul 27, 19:58

Is going to need rebase

Fabien updated this revision to Diff 22558.Tue, Jul 28, 06:59

Rebase, take ENABLE_JUNIT_REPORT into account

This revision is now accepted and ready to land.Tue, Jul 28, 06:59