In order to make backports go smoothly. (file was introduced in D717)
schancel jasonbcox deadalnix
- Group Reviewers
- rABC4967c68c3891: [rpc] Move tojson.h into blockchain.h
I think more and more stuff should be better organized. Core doesn't seem to care about separating stuff out much.
However, this is just my opinion. It seems Amaury shared it. I hope we don't prevent ourself from making needed organizational changes indefinitely because of backports.
Ah I see. Well the original organization was definitely crap, as both Core and Amaury recognized. I guess my mental picture here is that if the backport of PR10095 had already been done, then the tojson.h file would never have been made in the first place and a divergence would not have occurred. I also personally think the blockchain.h is the right place for these functions (being defined in blockchain.cpp).